Como buscar con dos variables en Excel: descubre nuestro secreto

Una de las consultas que con más frecuencia suelo recibir es cómo buscar a partir de dos variables en Excel. La verdad es que también he notado que esta es una consulta muy frecuente en foros y otras fuentes e inglés, pero en español existe poco material al respecto, así que en este artículo detallaré como podemos hacer este tipo de búsquedas, de un forma rápida y fácil.

[alert style="success"]Puedes descargar aquí un archivo con el que podrás practicar este ejercicio directamente en Excel[/alert]

¿Cómo buscar a partir de dos variables en Excel?

Supongamos que tenemos como punto de inicio una tabla de datos organizada como la de la figura adjunta, es decir una tabla no organizada como una base de datos sino cómo un sumario de datos por categorías. La primera fila y la primera columna describen el contenido de cada fila y columna respectivamente. Nuestro objetivo será conocer cuál es el valor intersección entre dos variables, por ejemplo, cuál es el valor de alcanzado en Julio en América, para esta forma buscar a partir de dos variables en Excel.

Para conocer el valor intersección de dos variables emplearemos la función Excel ÍNDICE para localizar entre el área de datos la fila y columna de nuestro interés. Para conocer cuál es la fila y columna de nuestro interés emplearemos la función Excel COINCIDIR.

En la celda donde deseemos realizar nuestra búsqueda aplicaremos la siguiente fórmula:

[message_box title="Fórmula para Buscar a partir de dos Variables" color="white"]=INDICE(Rango_donde_se_hará_la_búsqueda; COINCIDIR(Valor_Columna_a_Buscar;Rango_Primera_Columna;0); COINCIDIR(Valor_Fila_a_Buscar;Rango_Primera_Fila;0))[/message_box]

En esta fórmula:

  • Rango_donde_se hará_la_búsqueda, es igual al rango donde deseamos realizar nuestra búsqueda a partir de dos variables, excluyendo la primera fila y la primera columna que empleamos para identificar nuestros datos.
  • Valor_Columna_a_Buscar, es la variable que deseamos buscar en una columna específica. Puede ser una referencia a una celda, un valor numérico o de texto
  • Rango_Primera_Columna, es el rango donde se encuentra la columna que etiqueta nuestros datos.
  • Valor_Fila_a_Buscar, es la variable que deseamos buscar en una fila específica. Puede ser una referencia a una celda, un valor numérico o de texto
  • Rango_Primera_Fila, es el rango donde se encuentra la fila que etiqueta nuestros datos.

En nuestro ejemplo práctico la fórmula aplicada fue:

=INDICE($B$2:$F$13;COINCIDIR(“Julio”;$A$2:$A$13;0);COINCIDIR(“América”;$B$1:$F$1;0))

Donde:

El Rango_donde_se hará_la_búsqueda, es igual al rango $B$2:$F$13, tal como la zona sombreada en verde en la imagen anexa.

El Valor_Columna_a_buscar, es el valor de texto “Julio”, conforme la Primera_Columna, en nuestro caso es igual al rango $A$2:$A$13, tal como la zona sombreada en verde en la imagen anexa.

El Valor_Fila_a_buscar, es el valor de texto “América”, conforme el Rango_Primera_Fila, en nuestro caso es igual al rango $B$1:$F$1, tal como la zona sombreada en verde en la imagen anexa.

Una vez aplicada esta fórmula podremos realizar búsquedas de dos variables en Excel con tan solo cambiar los argumentos de los valores de fila y columna a buscar.

¿Es muy sencillo aplicarlo verdad? De cualquier forma no dudes en comentar este artículo si te queda alguna duda o deseas compartir otro método que conozcas para buscar a partir de dos variables en Excel.

Miembro fundador del Equipo EXCELLENTIAS.COM, Daniel es un apasionado emprendedor que busca innovar en el uso de MS Excel aplicado a la visualización de información y el empleo o desarrollo de nuevas herramientas que potencien la cognición humana. ¿Quieres conocer más de Daniel? ¡Síguelo en su Twitter (@d_cedeno ), síguelo en Google+ (Daniel Cedeño Urbina ) o envíale un correo electrónico (dcedeno@excellentias.com)!

3 Responses to “Como buscar con dos variables en Excel: descubre nuestro secreto”

  1. Información Bitacoras.com…

    Valora en Bitacoras.com: Sencilla fórmula de Excel que nos permite realizar búsquedas en una tabla de datos sobre la base de dos variables conocidas…

  2. Oigresserdna says:

    Hola, buenos dias, soy muy quinielero y me estoy confeccionando un programita de estadisticas de resultados de quinielas, hasta ahora me estoy manejando con filtros para armar las informaciones que me interesan, pero me gustaria encontrar alguna formula, probe con buscarV pero no logro lo que quiero, tengo una columna con fecha-otra con posiciones (que va del 1 al 20) otra con los numeros que salen sorteados y que coinciden con las posiciones, la pregunta es la siguiente, como armo una estadistica que me diga desde tal fecha hasta otra, que el nro tal en la posicion tal salio tantas veces?
    hasta ahora lo vengo haciendo con combinaciones de filtros, me podran dar una mano. gracias

  3. Donald Amador says:

    como seria buscar una fecha desde un dtpicker para que lo busque y me devuelva un valor de acuerdo a la fecha

Leave a Reply

You must be logged in to post a comment.